




Database Basics
Breed Mate is a proprietary database program designed specifically for fast 
operation, minimum memory requirements and small disk size.
All Breed Mate files end with a '.bmf' extension. Any single file usually contains all 
the data for a given breed of animal and any number of files can be maintained. For 
example you could keep all your Papillon records in a file called 'papillon.bmf' and 
keep Afghan records in a file called 'afghan.bmf' etc.
Like all relational databases, Breed Mate divides its database files into 'tables' 
where each table consists of rows and columns of data. Each row is called a record 
or 'entry' and each column is a field. A field in any particular record is called a cell. 
The first field in each table is called the primary key, eg in the ‘entry’ table the 
name of the entry is the primary key. The primary key must be unique and for this 
reason all entries must have a unique name.
Breed Mate allows you to add records or modify them at any time - there are no 
restrictions. There are however some nominal limits which have been set on various
sizes as follows:
· each file is nominally limited to 10 tables - normally you will only use the 
predefined tables anyway;
· each table has been nominally limited to 64,000 records;
· each record can contain up to 39 fields and a total of 2000 characters;
· each field can contain up to 254 characters.
A Breed Mate file will always contain at least one table - this is called the Entry 
table. This table contains a record for each of the animals in the database. 
The data in the fields is case insensitive, ie it does not matter whether you enter 
data in upper or lower or mixed case.
Note that spaces are important when attempting to match the sire field of one entry
against the name field of another entry. If they differ by one or more space 
characters inserted at the beginning, end or somewhere in the middle of the names 
then the match will fail. This would, for example, mean that a family tree or 
pedigree cannot be constructed.
Breed Mate 2.0 has a special function which strips extra spaces out of any data 
which is manually entered. This feature can be disabled via View - Options.
As mentioned previously, a BM file can contain more than one table. Apart from the 
tables mentioned in , all the other tables have, at this stage, no special meaning to 
BM, but should be considered reserved for future use.



File menu commands
The File menu offers the following commands:

New Creates a new document.
Open Opens an existing document.
Merge Add records from the selected Breed Mate file into the current 

file.
Import Import a CSV format file into the current table.
Close Closes an opened document.
Save Saves an opened document using the same file name.
Save As Saves an opened document to a specified file name.
Export As Saves the current table in the current database into a CSV 

(Comma Separated Value) text file.
Print Prints a document.
Print 
Preview

Displays the document on the screen as it would appear 
printed.

Print 
Setup

Selects a printer and printer connection.

Exit Exits Breed Mate.



Edit menu commands
The Edit menu offers the following commands:

Cut In database view, deletes a region of cells from the database and moves it 
to the clipboard.    In form edit view it copies entities to clipboard then 
deletes them.

Copy In database view, copies a region of cells from the database to the 
clipboard. In form edit view it copies the selected drawing entities to the 
clipboard.

Copy Picture In the forms view, this will copy all of the current form as a picture to the 
clipboard.

Paste In database view, pastes data from the clipboard into the database.
Insert In database view, inserts new records from the clipboard into the database .
Update Cell Data in the edit bar is transferred into the currently selected cell.
Clear In the database view it clears the contents of the currently selected cell. In 

form edit view it will delete the currently selected entities.
Add Entry A new entry (record) is added to the current table using the text in the Edit 

Bar as the name of the entry.
Copy Entry A new entry (record) is added to the current table using the text in the Edit 

Bar as the name of the entry. In addition, all the data of the currently 
selected record is copied to the new entry (useful for entering litters)

Change 
Case

Select a region in the database then use change case to change all the 
fileds in that region to the appropriate case, viz lower case, upper case, title 
case, sentence case.

Delete Deletes all of the currently selected records. An are-you-sure dialog is 
presented before this command completes.

Colour Edit colour of the selected node in the family tree.



View menu commands
The View menu offers the following commands:

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.
Freeze Field The currently selected field, and the fields to the left 

of it in the database view will remain on screen while 
horizontally scrolling. By default the name field is 
always frozen.

Marked Only This menu item indicates whether the database view 
is in Marked Only mode or not depending on whether 
it is ticked or not. The mode can be toggled by 
selecting this menu item. In Marked Only mode only 
marked lines are visible.

Database Bring database view for the currently selected entry 
to the front.

Form Bring forms view for the currently selected entry to 
the front.

Set Origin Sets the mouse coordinate origin to the last clicked 
mouse point.

Zoom In Available only in the forms view. Zooms the view to a 
greater magnification..

Zoom Out Available only in the forms view. Zooms the view to a 
smaller magnification.

DB Option Only available in the database view. Set default 
breed, per entry breed option and strip spaces.

Forms Option Only available in the forms view.



Entry Forms
Show entries can be produced by following these steps:

· First create a record for that show entry in the Show table. One way of doing this
is to select the entry in the Pedigree table, then hold the Control key down while
clicking on the Show button. Alternatively if you have already done a show entry
which is very similar to the one you are about to do, just select it in the Show 
table and use the duplicate command. The third way of creating an entry in the 
show table is simply to go to the Show table, enter then name of the entry in 
the edit box then hit F5.

· After filling in all the details of the show entry (including date, club, name, breed
class), double click on the record or just select it and click on the Form button.

· This will cause the currently selected from to be displayed. You may need to 
select the appropriate entry form from the Form menu.

· Next feed in a standard preprinted show entry into your printer and select File 
Print.

· Make sure that an entry in the Owners table exists for the owner of the entry 
otherwise the owners address, phone number and membership number will not 
appear. To create an entry, first select a cell containing the owners name, then 
in the database view select the Table menu and the 'Owner' table. Then hit the 
F5 key to create a record with the owners name (it should be in the Edit box 
because you previously selected it). Next enter the other details such as 
address, suburb, phone number.



Window menu commands
The Window menu offers the following commands, which enable you to arrange 
multiple views of multiple documents in the application window:

New Window Creates a new window that views the same 
document.

Cascade Arranges windows in an overlapped fashion.
Tile Arranges windows in non-overlapped tiles.
Arrange 

Icons
Arranges icons of closed windows.

Window 1, 2,
...

Goes to specified window.



Help menu commands
The Help menu offers the following commands, which provide you assistance with 
this application: 

Index Offers you an index to topics on which you can get 
help.

Using 
Help

Provides general instructions on using help.

About Displays the version number of this application.



New command (File menu)
When you create a new document by selecting New from the File menu, Breed Mate
makes an empty working file and all the operations that you perform within Breed 
Mate will be performed on that working copy, eg any changes made to the data will 
be to the working copy. To create a file on your hard disk you must issue the File-
Save or File-Save As commands.
BM has two types of files, viz:
· Database files - these end in '.bmf' and contain the information on your dogs, 

cats etc.
· Forms files - these end '.frm' and contain a set of individual forms, eg 

pedigrees, show entries. (If you want to create a new form rather than a form 
file use the Form - New command.)

Therefore when you issue the New command BM will ask you what type of 
document you wish to create. (Unless you have Breed Mate Pro you would never 
select 'BM Forms'.)

You can open an existing document with the Open command.
Shortcuts

Toolbar:
Keys: CTRL+N



Open command
Use this command to open an existing document in a new window.    You can open 
multiple documents at once.    Use the Window menu to switch among the multiple 
open documents.    See Window 1, 2, ... command.
You can create new documents with the New command.
When you open a file, Breed Mate makes a working copy of the file and all the 
operations that you perform within Breed Mate will be performed on that working 
copy, eg any changes made to the data will be to the working copy - the file that 
you originally opened is unchanged (until you do a save). An example of the Open 
File dialog box is shown in Figure 3.2.

Figure 2.2 Sample showing File Open dialog box.
Since Breed Mate has two types of file (database and forms) you may need to click 
on the 'List Files of Type:' list box. To see database files select 'BM Files (*.bmf)', to 
see forms files select 'Forms Files (*.frm)'. Note you will be supplied with two forms 
files, viz dog.frm and cat.frm - use which ever is appropriate for you.
To open a given file, first select the disc drive - this is done by clicking on the down 
arrow on the list box under 'Drives'. This will list all available drives - the C: drive is 
usually your hard drive and this is where you will usually store your files.
Next select the directory where the file is located. This is done by double clicking on
the directory name which is listed in the 'Directories' list box. The directory structure
is like a tree with several directories or 'branches'. To move to a particular directory 
it may be necessary to go back down the tree. This is done by double clicking on a 
previous directory, eg double clicking on the 'c:\' directory will return you to the root
of the tree.
The list box under 'File Name' lists all the files in the given directory which end in 
'.bmf'. To open one of these files select it and click on 'OK'. Files whose names do 
not end in '.bmf' will not be listed. Breed Mate can still read these files - either 
change the string '*.bmf' in the text box immediately under 'File Name' to '*.*' - or 
rename the file using the File Manager File 'Rename' function so that its name ends 
in '.bmf'.
Shortcuts

Toolbar:
Keys: CTRL+O





File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open.    This box lists files with the 
extension you select in the List Files of Type box. 

List Files of Type
Select the type of file you want to open:
*.BMF are the only native format file which BM will open

Drives
Select the drive in which Breed Mate stores the file that you want to open. 

Directories
Select the directory in which Breed Mate stores the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive 
letter. 



Close command (File menu)

Use this command to close all windows containing the active document.    Breed 
Mate suggests that you save changes to your document before you close it.    If you 
close a document without saving, you lose all changes made since the last time you
saved it.    Before closing an untitled document, Breed Mate displays the Save As 
dialog box and suggests that you name and save the document.

You can also close a document by using the Close icon on the document's window, 
as shown below:



Save command (File menu)

Use this command to save the active document to its current name and directory.    
When you save a document for the first time, Breed Mate displays the Save As 
dialog box so you can name your document.    If you want to change the name and 
directory of an existing document before you save it, choose the Save As command.

Shortcuts

Toolbar:
Keys: CTRL+S



Save As command (File menu)

Use this command to save and name the active document.    Breed Mate displays 
the Save As dialog box so you can name your document.    

To save a document with its existing name and directory, use the Save command.



File Save As dialog box

The following options allow you to specify the name and location of the file you're 
about to save:
File Name

Type a new filename to save a document with a different name.    A filename can 
contain up to eight characters and an extension of up to three characters.    
Breed Mate adds the extension you specify in the Save File As Type box.

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.

Network...
Choose this button to connect to a network location, assigning it a new drive 
letter. 



1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the 
last four documents you closed.    Choose the number that corresponds with the 
document you want to open.



Export As command (File menu)

Use this command to copy the contents of your current table to a Comma Separated
Value (CSV) format text file.

File in this format can be read by word processors and spreadsheets. It consists of a 
line of text for each record, with fields separated by commas. The fields are output 
in the same order as they appear in the database view.

After executing this command you will be prompted with a Save As dialog box.



Import command (File menu)

The Breed Mate database file is in a proprietary format, but you can import and 
export data in a CSV format. Note you can also directly copy and paste between 
Breed Mate and other Windows programs such as Microsoft’s Excel and Word.

The CSV format is a Comma Separated Value format which is an ASCII text file which
consists of a single line for each entry. All the fields in that line are separated by 
commas. The fields are in the order listed in the database view, viz name, sex, date 
of birth, sire, dam, etc.

An example of a CSV entry is shown below (note it is broken over the line because it
is too long to show here but in reality it must be a single line)    
Entry’s Name,M,2/1/91,Sires name,Dams Name,N88888,CH.,CDX.,B/W,Owners 
Name,Breeders Name,,3:3

Note: where a field is empty, the commas must still appear. Also do not put extra 
spaces in any of the fields.

A CSV file can be read into most spreadsheets, eg Microsoft’s Excel. Excel will also 
let you modify the file, reorder fields or entries and modify them. The file can then 
be written back to disk and imported back into Breed Mate.
To import a file, select Import from the File menu. This will give you a File Open 
dialog box. Select the disk drive, directory and then file that you want to read in and
click the OK button. Note that if an entry being imported already exists in the 
database, then that entry will not be read in.

Note: Both export and import work only on the current table.

Note: Entries which have just been added will be marked to allow easy identification. To
remove these marks select Clear All from the Mark menu.

After executing this command you will be prompted with an Open dialog box.



Merge command (File menu)

Use this command to read in records from another database into your current 
database. Entries which have the same primary key (name field) as existing entries 
in your database will not be copied across. New entries are marked (hilighted in 
light blue).

After executing this command you will be prompted with an Open dialog box.



Exit command (File menu)

Use this command to end your Breed Mate session.    You can also use the Close 
command on the application Control menu.    Breed Mate prompts you to save 
documents with unsaved changes.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Cut command
Use this command to remove the currently selected data from the document and 
put it on the clipboard.    This command is unavailable if there is no data currently 
selected.
Cutting data to the clipboard replaces the contents previously stored there.
Note that if the currently selected region includes the name field then this 
command will not succeed. Instead the user should copy then delete the entries.

Shortcuts

Toolbar:
Keys: CTRL+X



Copy command (Edit menu)
In the database view, the currently selected region is copied to the clipboard. It is in 
a text record format which can be directly pasted into word processors or 
spreadsheets.
If the database view is in the View-Marked Only mode, then only marked entries are 
copied. It is possible therefore to say mark all ancestors of a particular entry, switch 
to View-Marked Only mode, copy them to the clipboard and paste them into a new 
database which would then only contain that entry and its ancestors.
In the form edit view, the copy command will copy the selected entities to the 
clipboard. It may then be pasted into the same form or another selected form. This 
is an easy way to copy fields or other features that you want from one form to 
antoher.
Copying data to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
Keys: CTRL+C



Paste command (Edit menu)
Use this command in the database view to paste a copy of the clipboard contents 
over a region. The location of the paste region is determined by the currently 
selected cell, which will be the top left hand corner.
The extent of the paste region is determined by the clipboard data. If for example, 
an area of four columns by seven rows of data had been copied from a spreadsheet,
then the region it would cover in BM is four fields by seven entries.
This command is unavailable if the clipboard is empty. If the currently selected cell 
is in the name field then the command is also not available - instead the Insert 
command is available.
In the form edit edit view, this command will copy any drawing entities in the 
clipboard which were placed there by a previous Copy command, into the the 
currently selected form at the last position the mouse was clicked at.

Shortcuts

Toolbar:
Keys: CTRL+V



Insert command (Edit menu)
Use this command in the database view to insert a copy of the clipboard contents as
new entries to the current table.
This command is unavailable if the clipboard is empty or if the currently selected 
cell is not in the first field.

Shortcuts
Keys: CTRL+I



Add Entry command (Edit menu)

First enter the name of the new entry into the Edit Bar then use this command in 
the database or form view to add a new entry to the current table.
An entry will not be added if an entry already exists with the same name.
The add entry function can be performed from the database or form view.
To add an entry do the following:
· enter the name of the entry in the Edit Box;
· then select Add Entry from the Edit menu; OR
· click the Add Entry button from the dialog bar (yellow arrow); OR
· hit the F5 key on the keyboard.
Once this is done a new entry appears in the database view with the name that you 
entered and in its alphabetically ordered position. An example can be seen in Figure 
4.1. In this example a new entry called 'American Pie' was added by first typing the 
entry’s name in the Edit Box and then using the mouse to click on the yellow arrow. 
Immediately after doing this Breed Mate will display the new entry in its alphabetic 
position in the database. Be careful not to insert a space before the entry, as 
computers interpret a space as coming before 'a' in the alphabet.

Figure 4.1 Example of adding an entry
Note: Entries which have been added will have their name field marked, ie 
highlighted. This will occur whether the entry was added manually, or by importing 
or merging. 
Shortcuts

Keys: F5
Buttons: Single yellow arrow



Copy Entry command
First enter the name of the new entry into the Edit Bar then use this command in 
the database view to add a new entry to the current table. This command is similar 
to Add Entry - but in addition it will copy all the fields (except the first field - usually 
the name field) of the currently selected entry to the newly created entry (useful for
entering litters).
An entry will not be added if an entry already exists with the same name.

Shortcuts
Keys: F6
Buttons: Double yellow arrow



Delete Entry command
Deletes all entries in the current selection in the current table.
A warning dialog is issued first.
If the database view is in the View-Marked Only mode, then only marked entries are 
deleted.

Shortcuts
Keys: F7



Update Cell command (Edit menu)
Each entry contains a number of fields called cells. Editing an entry involves 
updating the contents of a cell. To update a cell in the database do the following:

· First select that cell by clicking on it in the database view    it will then be highlighted in 
yellow.

· The contents of the selected cell will appear in the Edit Bar where it can now be 
modified.

· To add text at some point in the Edit Bar just click at that point and start typing.
· To delete text in the Edit Bar just swipe the mouse across the text to be deleted and hit 

the delete key or backspace key. Alternatively insert the cursor immediately after the 
text to be deleted and hit the backspace key for each character to be deleted.

· The final step is to replace the modified text in the Edit Bar back into the database cell. 
This can be done in two ways either hit the enter key or click on the tick button in the 
dialog bar. Note that when you do this the cell to the right of that cell becomes the new 
selected cell this makes it easy to keep adding data to consecutive fields.

Note that cells can be selected by simply clicking on them or by using the cursor 
keys (up, down, left and right arrow). 
It is also possible to quickly delete the contents of the cell. First select the cell then 
just hit Ctrl+Delete.

Note: When the sire and dam fields are changed, Breed Mate will do a quick check to 
see if an entry for these names exists and, if it does not then the field is 
highlighted in cyan.

Shortcuts
Keys: Enter
Button: Green Tick



Clear Command (Edit menu)
This command is the same as hitting the Delete key. 
In the database view it deletes the contents of the current cell. The other fields are 
untouched.

Shortcuts
Keys: CTRL+Delete



Colour command
Only available in the form view, this command allows the user to change the colours
used for repeat entries - usually in the 8 generation family tree.
First make sure that View-Options-Show Repeat Marks is selected. Then select a 
record on the tree, whose colour you wish to change, then select this command. A 
standard colour dialog box is brought up Choose Color dialog box.
Any changes made to the 32 available colours will be saved in the form file but only 
if you select Save Form before exiting.



Toolbar command
Use this command to display and hide the Toolbar, which includes buttons for some 
of the most common commands in Breed Mate, such as File Open.    A check mark 
appears next to the menu item when the Toolbar is displayed.

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu 
bar.    The toolbar provides quick mouse access to many tools used in Breed Mate,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

Click To

Open a new document.

Open an existing document.    Breed Mate displays the Open dialog box, in 
which you can locate and open the desired file.

Save the active document or template with its current name.    If you have not
named the document, Breed Mate displays the Save As dialog box.

Remove selected data from the document and stores it on the clipboard.

Copy the selection to the clipboard.

Insert the contents of the clipboard at the insertion point.



Status Bar command
Use this command to display and hide the Status Bar, which describes the action to 
be executed by the selected menu item or depressed toolbar button, and keyboard 
latch state. A check mark appears next to the menu item when the Status Bar is 
displayed.
See Status Bar for help on using the status bar.



Status Bar

The status bar is displayed at the bottom of the Breed Mate window.    To display or 
hide the status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow
keys to navigate through menus.    This area similarly shows messages that describe
the actions of toolbar buttons as you depress them, before releasing them.    If after 
viewing the description of the toolbar button command you wish not to execute the 
command, then release the mouse button while the pointer is off the toolbar button.

The middle area of the status bar, in the database view, will show the entry at the 
top of the view when the horizontal scroll button is being dragged. This allows the 
user to quickly zoom to an entry in the database.

The right areas of the status bar indicate which of the following keys are latched 
down:

Indicator Description
CAP The Caps Lock key is latched down.
NUM The Num Lock key is latched down.
SCRL The Scroll Lock key is latched down.



Database command
This command will cause the database view to be presented. This can also be 
accomplished by clicking on the toolbar button or from the forms view, just double 
click on a node and the database view is presented with the node’s entry selected.



DB Option
Select this menu item to change some of the display options for the database via 
the dialog box shown below. 

Database Options Dialog Box
The options are:
· Strip Out Extra Spaces on Entry - this option when selected will cause any 

extra spaces to be removed from data as it is manually entered. It has no 
effect on data which is already in the database, or which is entered via other 
means, eg paste, import, merge. This option will strip out any spaces before or 
after a name and will remove any more than a single space from between 
words in the name. This option is useful for avoiding the entry of names which 
appear identical but are not thus causing branches of a family tree not to 
appear.

· Use Per Entry Breed - some forms have a field called breed. This field can 
optionally be set to come from the breed field which is contained whithin each 
entry, or it can come from the single breed name stored in the database file. 
Normally you would store only a single breed type in a particular file, but some
breeds, eg Group II cats, will intermix breeds and they would therefore use this
option.

· Breed - this is the default breed which is stored in the database file and will be
used wherever a breed field occurs on a form (unless the previous option is 
selected).



Set Origin
The current X Y position of the mouse cursor is always displayed in the status bar as
shown below. The origin (zero, zero point) is initially the top left corner of the page 
but the set origin command will set it to the last point the mouse was clicked at.

X Y Coordinates Shown in Status Bar



Freeze Field command
This command allows a selected group of fields to be frozen so that when scrolling 
horizontally, these cells will not be scrolled and will always remain on screen. The 
group of fields must be contiguous and must include the name field.
First select a cell in the field which is the the rightmost field in the group of fields to 
be frozen, then select View-Freeze Field. For example to freeze the name, sex and 
DOB fields, select any cell which is in the DOB field then select View-Freeze Field.
Note the name field is always frozen.



Marked Onlycommand
Select this menu item to toggle the database view display mode between view all 
and view marked only. The menu item is checked when the view is in the marked 
only mode, and unchecked otherwise.
In the Marked Only mode, only marked entries are displayed. Also when printing, 
only marked entries will be printed and when copying a region to the clipboard 
using the Edit-Copy command only marked entries in the selected region are 
copied.
This features can be very powerful - here are three examples:
· you could mark all carriers of a particular genetic disease using the Mark-Substring 

command, then View-Marked Only to see the condensed list or print it;
· mark all ancestors of a particular entry, then View-Marked Only, select the entire view 

by clicking in the top left black corner, then select Edit-Copy, create a new database 
using File-New and do an Edit-Insert to paste thes into the new database;

· mark all unreferenced dogs (those that have no progeny in the database), then View-
Marked Only, select the entire view by clicking in the top left black corner, then select 
Edit-Delete to remove all those entries;



Zoom In command
This command is only available in the family tree and pedigree views. It causes in 
an increase in the view magnification, making obects appear larger; naturally when 
this occurs, less of the overall view can be seen at one time.
The view magnification is available in steps of 25%, 50%, 75%, 100%, 150%, 200% 
of actual size.



Zoom Out command
This command is only available in the family tree and pedigree views. It causes in 
an decrease in the view magnification, making obects appear smaller; when this 
occurs, more of the overall view can be seen at one time. This command is useful 
when trying to see the overall appearance of a family tree or pedigree.
The view magnification is available in steps of 25%, 50%, 75%, 100%, 150%, 200% 
of actual size.



New command

Use this command to open a new window with the same contents as the active 
window.    You can open multiple document windows to display different parts or 
views of a document at the same time.    If you change the contents in one window, 
all other windows containing the same document reflect those changes.    When you 
open a new window, it becomes the active window and is displayed on top of all 
other open windows.



Cascade command

Use this command to arrange multiple opened windows in an overlapped fashion. 



Tile command

Use this command to arrange multiple opened windows in a non-overlapped 
fashion.



Window Arrange Icons Command

Use this command to arrange the icons for minimized windows at the bottom of the 
main window.    If there is an open document window at the bottom of the main 
window, then some or all of the icons may not be visible because they will be 
underneath this document window.



1, 2, ... command

Breed Mate displays a list of currently open document windows at the bottom of the 
Window menu.    A check mark appears in front of the document name of the active 
window.    Choose a document from this list to make its window active.    



Index command

Use this command to display the opening screen of Help.    From the opening screen,
you can jump to step-by-step instructions for using Breed Mate and various types of 
reference information.    
Once you open Help, you can click the Contents button whenever you want to 
return to the opening screen.



Using Help command (Help menu)

Use this command for instructions about using Help.



About command

Use this command to display the copyright notice and version number of your copy 
of Breed Mate.



Context Help command 

Use the Context Help command to obtain help on some portion of Breed Mate.    
When you choose the Toolbar's Context Help button, the mouse pointer will change 
to an arrow and question mark.    Then click somewhere in the Breed Mate window, 
such as another Toolbar button.    The Help topic will be shown for the item you 
clicked.

Shortcut
Keys: SHIFT+F1



Title Bar

<< Show your application's title bar here. >>

The title bar is located along the top of a window.    It contains the name of the 
application and document.

To move the window, drag the title bar.    Note: You can also move dialog boxes by 
dragging their title bars.

A title bar may contain the following elements:
Application Control-menu button
Document Control-menu button
Maximize button
Minimize button
Name of the application
Name of the document
Restore button



Scroll bars

Displayed at the right and bottom edges of the document window.    The scroll boxes
inside the scroll bars indicate your vertical and horizontal location in the document.  
You can use the mouse to scroll to other parts of the document.



Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window
with the arrow keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the 

pointer to the border you want to move.    
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active 
window or dialog box with the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize command (application Control menu)

Use this command to reduce the Breed Mate window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title 
bar.

Keys: CTRL+F10 enlarges a document window.



Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note:    If you have multiple windows open for a single document, the Close 
command on the document Control menu closes only one window at a time.    You 
can close all windows at once with the Close command on the File menu.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the <<YourType>> window or dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you 
chose the Maximize or Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to 
switch to or close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box 
with the following options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This 
option does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does 
not affect applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



Choose Color dialog box

This command is only available from the family tree view under the Edit menu, 
Colour... item.
The colours which are used to shade repeated entries can be altered by first 
selecting an entry which has that colour and then selecting the Colour... item from 
the edit menu.
This will display a dialog box which will show the selected colour in a number of 
ways, each of which can be edited.
The first two ways that the colour is shown is as red, green and blue values and as 
hue, saturation and luminance values. The maximum value for any of these fields is 
255 and the minimum is 0.
The third way of editing the colour is graphically by clicking on the hue/saturation 
colour map and by dragging the cursor on the luminance bar.
Any changes made to any colours will be saved on exit from Breed Mate and will be 
restored when Breed Mate is started again.



Modifying the Document





No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.
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Database Tables
Breed Mate allows for up to 10 tables (arbitrary limit) within a single database file. 
The first four tables are reserved as follows:
· Pedigree table - this contains the names of the various entries in alphabetic 
order and each entry contains such data as sire, dam, date of birth, sex etc.

· Owner table - this contains details about owner’s or breeder’s name, address, 
suburb, postcode, phone, membership number, club etc. The Owner table is not 
used at the moment but may be linked with the owner field in the Pedigree table
in future versions.

· Show table - this contains information related to show results. The fields 
provided are date, name (of the entry), club, show, judge, grading (result), class 
entered, 1st place, 2nd place, 3rd place, challenge.

· Litter table - this contains information common to a given litter. The fields 
provided are a unique litter name, total born, number culled / died, number 
fostered.

· Medical Table - contains medical / worming events. Basically records the 
dog/cat, the date, condition, result, vet (if applicable).

· Heats / Mates - used for recording the heats and if applicable mates.
7.1 Pedigree Table
This is the main table in any breed file. It contains details on entries as follows:

· Name- the name of the entry. Some older exhibits may have simple names, eg 
Cap. This can make it difficult to distinguish other dogs of the same name so 
where this occurs you can precede the name with the owner, eg Wilsons Cap. 
For consistency do not include punctuation marks such as apostrophes and 
hyphens in the name. Also some dogs have exactly the same name but may be 
the second, third etc - in these cases add '2nd' or '3rd' etc as appropriate. In 
some cases it may be appropriate to have the name followed by a unique 
number, eg 'Cap 2038'.

· Sex - this must be 'M' for a male or 'F' for a female.
· Date of Birth (DOB) - the format is not fixed but for consistency should be 

dd/mm/yy, eg 27 August 1994 would be 27/8/91.
· Name of Sire - this name should match another entry in the table so that a 

family tree or pedigree can be constructed;
· Name of Dam - same as for sire;
· Registration Number ;
· Titles - this is the list of titles the entry has been awarded. The format is not 

fixed but for consistency all titles should be in capitals with no intervening full 
stops and they should be terminated with a full stop. In the case of multiple 
titles just run them with one space between. For Australian Champion just enter 
'CH.'



· Obedience - obedience / agility titles. The format is not fixed but for consistency 
all titles should be in capitals with no intervening full stops and each title should
be terminated with a full stop. In the case of multiple titles just run them with 
one space between - eg 'CD. CDX.'.

· Colour - there is no specific format, but for consistency use the abbreviations 
commonly used for the breed.

· Genetic Disease - this is a list of all the genetic diseases, or suspected diseases 
that an entry carries. For consistency use two or three letter abbreviations for 
diseases and separate them with spaces. We suggest that suspected carriers 
are marked with the disease abbreviation only, known carriers are suffixed with 
a ‘+’ and affected dogs are suffixed with a ‘++’. For example, an entry which is 
suspected of carrying Ceroid Lipofucinosis, is a known carrier of Collie Eye 
Anomoly, and is affected by OCD would have a GD field of 'CL CEA+ OCD++'.

Note:You can use the Mark Substring command with a search field of 'GD' and a 
substring of say 'CL' to mark all entries which are suspected carriers, known 
carriers or affected by the CL genetic disease. This would show up on the family 
tree if Mark Shaded is selected under View-Options. If the search string was set 
to ‘CL+’ then only known carriers or affected would be marked. If the search 
string was set to ‘CL++’ then only affected entries would be marked.

· Owned By - the name of the entry’s owner - this information is used on pedigree
and show entry forms;

· Bred By - the name of the entry’s breeder - this information is used on pedigree 
and show entry forms;

· Hip Score - this will typically be entered as two numbers separated by a colon 
(':'), the first number is the left hip score, the second is the right hip score.

· Height - typically the height in centimetres.
· Pet name - (also Call Name) or other names by which the entry is known.
· Imported - put import information here, eg ‘Imp NZ’ to indicate imported from 

New Zealand.
· Tatoo - the tatoo number of the entry. Some dog breeders will place a tatoo on 

the inside of the ear to identify the dog.
· Surveyor - this and the following field are used by some breeds, eg German 

Shepherds
· Classification - the classification given by the Surveyor.
· Date Sold - this is used only if you have sold the dog/cat.
· Breed - in cases where the breed of an entry may be different for each entry, eg 

Group II cats. Normally you would not use this field.;
· Genotype;
· Notes - private notes which should not appear on a pedigree;
· Elbow Score;
· Register - name of the registering body for the registration number of this entry;
· Certifications - list of certifications obtained, eg OFA Good.



· Comment - a comment field which could be included in a pedigree certificate.
· Further user defined fields.
7.2 Owner Table
The owner table is used to provide additional details about an owner or breeder, eg 
their address and phone number. This data is typically used in show entry form and 
also in some pedigree forms that show the owner or breeder and their address.

· Owner’s Name - the name of an owner or breeder. It should match a name in 
the Owned By or the Bred By fields in the Entry table.

· Street Address - the street number and name, eg 34 Bartholomew Ave.
· Suburb - eg Alexandria.
· State - eg VIC;
· Postcode
· Home Phone No.
· Work Phone No.
· Membership No.
· Club;
7.3 Show Table
This table is used for two purposes. Firstly to store all the details for a show entry 
and secondly for storing the results of the show. The fields in the table are:

· Name - name of the entry for which the show entry is made, eg if you are 
entering your dog or cat 'Kepeetoo Parfais' in a show then this is the name you 
would put in this field. The name should also exist as a record in the entry table 
so that other details for the show entry can be provided, eg sire, dam, 
registrations.

· Show Date - date on which the show was conducted, or for multi day shows, just
the first date.

· Sponsoring Club - this is the field that normally appears on the show entry.
· Show - the name of the show being entered.
· Cost - total cost for this show entry.
· Cheque No. - used for printing on some show entrys and for records.
· Breed Class.
· Special Class.
· Trial Class.
· Judge’s Name - the name of the judge for your breed class.
· Result - the result your entry achieved.
· 1st - name of entry who received 1st place in the breed class.
· 2nd - name of entry who received 2nd place in the breed class.



· 3rd - name of entry who received 3rd place in the breed class.
· Challenge - name of entry who received the challenge
· Best of Breed - name of entry who received best of breed.
· Comments - regarding the judging or other entries.
· Date Entered - the date the show entry was posted.
· Number of entries - in the breed class or other class.
· Number of Points - achieved if a challenge or similar win was obtained.
· Grading - in some shows, entries are given a grading, eg fine, excellent, good.
7.4 Litter Table
This table is used for recording details on litters. The fields in the table are:

· Dam’s Name .
· Date Whelped.
· Sire’s Name.
· Females Born.
· Males Born.
· Females Reared.
· Males Reared.
· Died.
· Fostered.
· Service Date.
· Date Notified - to the registering body.
· Comments.
7.5 Medical Table
This table is used for recording details on medical events. These events do not need
to be vet events but can also include worming eg. The fields in the table are:

· Name - of the entry.
· Service - the service performed on this occasion (can include worming)
· Result
· Cost - if any.
· Return Date - if any. Can also be date for next worming.
7.6 Heats/Mates Table
This table is used for recording details on an entries heats and matings. The fields in
the table are:

· Dam’s Name - of the entry.



· Date Fertile - the date at which it was estimated she became fertile.
· Date 1st Mating
· Date 2nd Mating - if any.
· Mated With - if any.
· Mated By - stud assistance.
· Comments.



Print command

Use this command to print a document.      This command presents a Print dialog 
box, where you may specify the range of pages to be printed, the number of copies,
the destination printer, and other printer setup options.
Breed Mate allows you to print from any of the three possible views, ie database, 
forms, forms designer.
To print the various views just:
· Select the view first.
· If in database view select Print Setup from the File and set the paper size and 

orientation. This is not required in forms or forms designer views.
· Select Print from the File menu or select Print Preview from the File menu.
In print preview you can see how the page will look when it is printed.
Note: If more than one cell is currently selected then Print Preview will only show 
the selected lines.
In the case of forms, Breed Mate has an option to fit the print out to the paper size. 
Hence even if a form has been designed for say A3, it can still be printed on A4 by 
just using Print Setup to select the A4 size and selecting the 'Fit To Page' option.
In the case of database printing, the printout will always be the same size 
regardless of paper size. To fit more columns in your printout select the landscape 
orientation from the Print Setup menu under File.
An extra option is available from the database view when printing. It is possible to 
print just a part of the database by selecting a region then from the Print dialog 
choose Selection under Print Range.
Also in the database view, if the view is in Marked Only mode, then only marked 
entries are shown on screen, and when printing, only marked entries will be printed.
The select region option is also available in this mode.
Note that the database printout will print starting from the left-most column shown 
on your screen, therefore if you have printed out data and it only goes up to the 
fourth column, you can print the fifth column onwards by scrolling the database 
view to the right until the fifth column is the left-most column displayed, then do 
another print.
Shortcuts

Toolbar:
Keys: CTRL+P



Print dialog box

The following options allow you to specify how the document should be printed:
Printer

This is the active printer and printer connection.    Choose the Setup option to 
change the printer and printer connection.

Setup
Displays a Print Setup dialog box, so    you can select a printer and printer 
connection.

Print Range
Specify the pages you want to print:
All Prints the entire document.
Selectio
n

Prints the currently selected text.

Pages Prints the range of pages you specify in the From and To 
boxes.

Copies
Specify the number of copies you want to print for the above page range.

Collate Copies
Prints copies in page number order, instead of separated multiple copies of each 
page.

Print Quality
Select the quality of the printing.    Generally, lower quality printing takes less 
time to produce.



Print Progress Dialog

The Printing dialog box is shown during the time that <<YourApp>> is sending 
output to the printer.    The page number indicates the progress of the printing.

To abort printing, choose Cancel.



Print Preview command (File menu)

Use this command to display the active document as it would appear when printed.  
When you choose this command, the main window will be replaced with a print 
preview window in which one or two pages will be displayed in their printed format.  
The print preview toolbar offers you options to view either one or two pages at a 
time; move back and forth through the document; zoom in and out of pages; and 
initiate a print job.



Print Preview toolbar

The print preview toolbar offers you the following options:
Print

Bring up the print dialog box, to start a print job.
Next Page

Preview the next printed page.
Prev Page

Preview the previous printed page.
One Page / Two Page

Preview one or two printed pages at a time.
Zoom In

Take a closer look at the printed page.
Zoom Out

Take a larger look at the printed page.
Close

Return from print preview to the editing window.



Print Setup command (File menu)

Use this command to select a printer and a printer connection.    This command 
presents a Print Setup dialog box, where you specify the printer and its connection.
Each form stores its own paper size and orientation therefore you need only do a 
print setup once for each form.

Figure 3.4 Sample showing Forms Print Setup dialog box.
The Fit To Page check box can be used to fit any size forms to the current page size. 
For example if you have an A3 pedigree design that you want to print at A4 size just
change the page size of the form to A4 and set Fit To Page.
The page size width and height should be set only if paper size is set to 'User 
Defined' - otherwise they will simply be ignored. This feature would normally only be
used for unusual paper sizes, eg show entries.
The horizontal and vertical pages boxes allow you to create a form consisting of 
‘tiles’ of paper. The tiles are shown in the forms view with a grey line as the 
boundary between each page.
Normally you would only have 1 horizontal by 1 vertical page, ie a single page, but 
if you selected 3 horizontal by 2 vertical, then this is the number of pages that will 
be displayed in your forms view. If you also select Fit To Page, then you can print out
a much larger form. eg pedigree. It will come out of the printer on 6 separate pieces
of paper, and when these are assembled in the same order as on screen, then you 
will have a correspondingly larger pedigree etc. Generally this feature will only be a 
novelty but it does have a practical use, eg in the case of printing the A3 German 
Shephard pedigree on an A4 printer - just fold the A3 pedigree in half and print each
side in turn.



Print Setup dialog box
The following options allow you to select the destination printer and its connection.
Printer

Select the printer you want to use.    Choose the Default Printer; or choose the 
Specific Printer option and select one of the current installed printers shown in 
the box.    You install printers and configure ports using the Windows Control 
Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources.    Specify the tray 
here.

Options
Displays a dialog box where you can make additional choices about printing, 
specific to the type of printer you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive 
letter.



Page Setup command (File menu)

<< Write application-specific help here. >>
    



Features
Breed Mate is a versatile and powerful pedigree program, in some ways its too 
powerful! This is why, starting with Version 2.0, we have introduced two separate 
products, Breed Mate and Breed Mate Pro. Breed Mate Version 2.0 has even more 
features than the previous Version 1.5 and it still retains Breed Mate’s famous ease 
of use.
Breed Mate Pro Version 2.0 however is for more experienced users and its most 
obvious feature is that it allows the user to create their own forms, or modify 
existing forms! 
To simplify things even further, the manual has now been divided into three parts as
follows:
· Breed Mate User Guide    - 'how to' approach with emphasis on commonly 

performed activities.
· Breed Mate User Reference - a command based description of all available 

functions.
· Breed Mate Pro Manual    - describes additional features of Breed Mate Pro 

inclduig the extensive from editing and creation functions and the picture 
extensionss.

1.1 Database Features

· Create databases of dogs or other animals. Normally each breed would have its 
own database file. Breed Mate places no limits on the number of files you keep.

· Each breed file can store at least 64,000 entries (assumes 8MB RAM minimum) 
and each entry has 39 data fields including fields for name, sex, date of birth, 
sire, dam, registration, show titles, obediance, colour, genetic diseases etc.

· Read databases created by other people or merge other databases into your 
existing database.

· New entries can be added to the database or existing entries modified at any 
time.

· Data can be imported from virtually any spreadsheet or word processing 
package.

· Family trees, pedigrees and databases can be printed on A4, A3 or any size 
paper supported by your printer and Windows 3.1.

· Extra spaces in names can optionally be removed. This is handy because extra 
‘hidden’ spaces are often the cause of names not matching and resulting in 
incomplete pedigrees.

1.2 Find / Replace Features

· A Find Fast command will find the first entry in the database that matches the 
letters you’ve entered. For example if you entered the letter ‘c’ in the edit box 
and selected Find Fast then it would find the first entry starting with a ‘c’. 
Similarly you can enter a complete name or just a kennel prefix, eg if you 



entered ‘Chatswood FineGlen’ in the edit box and clicked on Find Fast then it 
would find the first entry in the database with the same prefix of ‘Chatswood’ 
and possibly a different suffix eg ‘Chatswood Amelia’. This command is useful 
for quickly moving to a part of the database or if a sire or dam field has a name 
that you cannot find with the Find Name command (perhaps because it is not an
exact match).

· Find Replace command. This is in the form of a dialog box which allows you to 
search for a string and replace it with another string. It has options for case 
sensitive searching and matching whole words. A ‘Replace All’ button allows for 
rapid replacement of all occurences of a string. Find Replace can optionally 
operate over the whole of the currently selected table or a selected part of it, eg
just one field.

1.3 Marking Features
Marking is like doing a ‘select’ in some databases. You can select records based on 
various conditions. Selected records are shown marked in either red or blue and are 
visible in both database and forms views.

· Mark all the ancestors of a selected entry    then display another entry’s family 
tree with those marked ancestors allows common ancestors to be seen.

· Mark all the descendants of an entry    then display the family tree of another 
entry to see if or how the entry is descended from it.

· Unreferenced names, sires and dams can be automatically marked. This 
function allows typing errors in the data to be detected because, normally, the 
sire or dam field of one entry should match the name field of another entry.

· The database view has a ‘view marked only’ feature which will only show 
marked entries. This is a handy feature that allows you to mark all the ancestors
of an entry and then only display them. Another option is to mark all genetic 
disease carriers and only view them.

· Offspring can now be marked up to and including 1st, 2nd, 3rd, 4th or all 
generations.

· Siblings of a selected entry can be marked. There are four options, viz same 
sire; same dam; same sire and dam; same sire or same dam.

· A range of entries can be marked or cleared or have their marks inverted (ie 
marked entries become unmarked and vice versa).

1.4 General Features

· The ‘name’ field in the database view will always remain on screen when 
scrolling horizontally. In addition this ‘freeze field’ feature can be extended to 
include other fields.

· Extensive clipboard functions exist. You can cut, copy and paste selected 
sections of your database (from one cell to all of it) and transfer data between 
Breed Mate and other Windows programs directly, eg you could copy all marked 
entries to Microsoft’s Word or Excel or other popular word processors and 
spreadsheets.

· The forms view allows zooming. This is particularly useful when you want to get 



an overall view of a family tree or pedigree.
· Tables are named and can be accessed directly from the ‘Table’ menu.
· When dragging the scroll button in the database view the current entry at the 

top of that screen will be shown in the status bar. This allows rapid scrolling to a 
particular area of the database, eg entries starting with ‘p’.

· A drag and drop editing function allows the contents of one cell to be quickly 
copied to another cell. Just select a cell, then click the mouse in that cell and 
drag across to the cell you wish to copy to then release the mouse button.

· A Backtrack toolbar button will go back to the previous selected entry in the 
database view thus making it easy to navigate around when entering pedigrees.
The last 32,000 entries selected are recorded.



Search menu commands
The Search menu has commands for finding and optionally replacing data.
There are seven find commands available, viz Find Fast, Find Entry, Find Next, Find 
Previous Find Mark, Find Replace and Backtrack. All these commands, except Find 
Mark will perform a search of the database based on a search string entered in the 
Edit Box. If the search is succesfull then the ‘found’ cell will become the current 
selection (hilighted in yellow). If however, the Shift key is pressed when one of these
commands is invoked then, if the search is succesfull the current selection will be 
extended to the ‘found’ cell.
All the find commands except Find Replace are also available as toolbar buttons and
as keyboard commands.

Note: When the find command scrolls to a particular cell, the contents of 
the cell will not appear in the dialog bar. This is to prevent your 
search string from being overwritten.

Bright Idea: If you are examining prospective matings of several dogs to a 
single bitch (ie doing combined family trees) you could mark the 
bitch (clear all other marks then hit F8) select the dog, then, holding 
the Shift key down click on the Find Mark button - this will cause the 
region between the dog and bitch to be selected- then click the 
Show Family Tree button to get a combined family tree. After 
returning to the database view you can select another dog, then 
again hold shift and click on the Find Mark button to repeat the 
process for this dog.

Find Entry Searches the current table for an entry whose name exactly matches 
the text in the Edit Bar (search is case insensitive).

Find Fast Searches the current table for an entry whose name matches the text 
in the Edit Bar. Only as many letters as are entered in the search 
string need to match.

Find Next Searches the current table for an entry whose name or sire or dam 
field contains the text in the Edit Bar as a sub string (search is case 
insensitive). The search starts from the currently selected cell and 
proceeds forward, ie toward the end of the file

Find 
Previous 

Searches the current table for an entry whose name or sire or dam 
field contains the text in the Edit Bar as a sub string (search is case 
insensitive). The search starts from the currently selected cell and 
proceeds backward, ie toward the start of the file

Find Mark Searches the current table for an entry which is marked (name field is 
hilited in light blue).    The search starts from the currently selected 
cell and proceeds forward, ie toward the end of the file

Find 
Replace

Brings up a standard Find Replace dialog box.



Table menu commands
The Table menu has commands to add a new table or delete an existing table from the 
current database file.

The bottom of the Table menu lists all the tables in the currently selected database file with 
the current table shown ticked. Select one of these tables to make it the currentlyselected 
table. Note the database view can only show one table at a time.

Normally the following tables will exist: Entry, Owner, Show, Litters. Up to 10 tables can exist
in one file - the remaining tables are not used at this time but should be considered 
reserved.

For more information, select the Table menu command name.:

New Creates a new table within the current database file.
Delete Deletes the current table from the current database file.
Select Select a current table from the list of tables in the current database 

file.
Rename Change the name of the current table.



Mark menu commands
The Mark menu includes commands that mark a range of entries, or clear or invert.

For more information, select the Mark menu command name.:

Mark 
Overview

Describes marks in general

Set Sets the marks of selected entries.
Clear Clears the marks of selected entries.
Invert Inverts the marks of selected entries.
Mark Red All further marks will be in red.
Mark Blue All further marks will be in blue
AND Mark Logically AND the blue and red marks to produce red marks only.
OR Marks Logically OR the blue and red marks to produce red marks only.
Ancestors Marks the ancestors of a selected entry.
Descendants Marks descendants of the selcted entry.
Siblings Mark siblings of the selected entry.
Substrings Marks all entries that conatin the given substring in the selected field.
Unreferenced Marks unreferenced sires, dams and name fields.
Clear All Clears marks from all entries.



Mark Set command (Mark menu)

The Mark Set command will turn on the mark for all entries in the selected region regardless 
of whether they were already set or not.



Mark Invert command

The Mark Invert command will invert the mark on the name field for all entries in the 
selected region. Hence for entries in the selected region, those which are marked will be 
unmarked and vice versa.



Mark Clear command

The Mark Clear command will turn on the mark for all entries in the selected region 
regardless of whether they were already set or not.



Mark Ancestors command

The Mark Ancestors command will turn on the name mark for all ancestors of the selected 
entry.



Mark Descendants command

The Mark Descendants command has a sub menu which allows for marking descendants up 
to and including the 1st, 2nd, 3rd, 4th or all generations. For example select Mark 
Descendants-1st to mark all of an entries immediate offspring.



Mark Siblings command

The Mark Siblings command has a sub menu which allows for marking siblings which are, 
same sire only, same dam only, same sire and same dam, same sire or same dam.



Mark Substring command

The Mark Substring command will turn on the name mark for all entries which contain the 
substring in the Edit Bar in the currently selected field. For example, if in the genetic disease
field (GD) all carriers of the genetic disease CL contained the string CL in that field, then if 
the text CL was in the Edit Bar, and a cell in the GD field was currently selected then, BM 
would search the GD field of every record, and if it contained CL then it would be marked.



Mark Unreferenced command
The Mark Unreferenced command will turn on the name mark for all entries whose name 
field does not appear in the sire or dam field of any other entry (ie no progeny). Also the sire
and dam field of any entry will be marked if the name in that field does not appear in the 
name field of an entry (ie orphan).



Mark Clear All command

The Mark Clear All command removes all marks from all of the currently selected entries.



Find Fast command

This command will find the first entry in the database that matches the letters you’ve 
entered in the Edit Bar. For example if you entered the letter ‘c’ in the Edit Bar and selected 
Find Fast then it would find the first entry starting with a ‘c’. Similarly you can enter all or 
part of a kennel prefix and the first entry whose first characters match will be found, eg if 
you entered ‘cha’ then it would find the first entry starting with those three letters. In the 
case where a complete name is entered, this command discards any characters after the 
first space, hence if you entered ‘Chatswood FineGlen’ in the Edit Bar and clicked on Find 
Fast then this would be equivalent to having entered just ‘Chatswood’ and it would find the 
first entry in the database with the same prefix of ‘Chatswood’. This command is useful for 
quickly moving to a part of the database. Also if a sire or dam field has an incorrectly 
entered name that you cannot find with the Find Name command the Find Fast will get you 
at least to entries with the same kennel prefix.



Find Entry command

Searches the current table for an entry whose name exactly matches the text in the Edit Bar 
(search is case insensitive). If the Shift key is pressed it will extend the selection to the found
entry.



Find Next command

This will search the database in the forward direction from the current position, ie the 
currently highlighted entry. It searches the name, sire and dam fields for an entry that 
matches the text in the Edit Bar. The text only needs to match part of the names, eg if the 
Edit Bar contained the text Mac then this would match MacSpade, MacDowel, Bemaced etc. 
If it does not find a match it starts searching again from the top of the file until it returns to 
the current position. If no match is found a dialog box with the message No occurrences of 
string found is issued.



Find Previous command

Searches the current table for an entry whose name or sire or dam field contains the text in 
the Edit Bar as a sub string (search is case insensitive). The search starts from the currently 
selected cell and proceeds backward, ie toward the start of the file.    If the Shift key is 
pressed it will extend the selection to the found entry.



Find Mark command

Searches the current table for an entry whose name, sire or dam field is marked.    The 
search starts from the currently selected cell and proceeds forward, ie toward the end of the 
file. If the Shift key is pressed it will extend the selection to the found entry.

The Shift feature is useful when doing prospective matings. For example, mark a single bitch
(no other entries marked) go to a dog, then Find Mark with Shift pressed. The region 
between and inclusive of the dog and bitch will be marked - then select View-Form to see the
pedigree of the mating.



Find Replace command
This command allows the user to find or find/replace a string in either the whole of 
the current table, or the currently selected region. If only a single cell is currently 
selected then find replace will operate on the whole table, otherwise it will only 
operate on the currently selected region. If for example you selected on whole 
column (ie field) by clicking in the heading field then find replace will only operate 
on that column (useful for changing data only in specific fields).
Find Replace is implemented as a separate modeless dialog box (this means you 
can switch between the dialog and the database view by clicking on either - the 
dialog box will not go away unless you click on the Cancel button), as shown in 
Figure 5.1 and it allows the user to enter a find string and a replace string and then 
to perform one of three possible commands:

Find starting from the first cell after the current cell this will find the 
next occurrence of the find string by searching all the fields of 
the database ;

Replace this will replace the currently found occurence of the find string 
with the replacement string and then find the next occurrence 
of the find string as indicated previously;

Replace All this will search the entire file and replace every occurrence of 
the find string with the replace string ;

Warning: The Replace All command restarts the search replace mechanism hence if you 
had previously selected the Replace command with the same search string 
then the Replace All command could potentially repeat the replacement on 
that entry, eg if you did a Replace of ‘roo’ with ‘rooroo’ then did a Replace 
All the first replace would be repeated and become ‘roorooroo’.

Warning: If the find replace operation results in the contents of a name field being 
changed to the name of an already existing entry - then the change will not 
occur, eg if you changed one record with a name filed of 'Brown’s Meg' to 
'Browns Meg' and a record with the name Browns Meg already existed then 
the change would not occur.

There are also two search options:
Match Case the case of the letters must match if this checkbox is crossed;
Whole Word the find string must be a whole word or words, eg if searching 

for 'fred' then the following data fields would match 'fred hello', 
'hello fred', hello fred again, but the following would not match 
'frederick', 'alfred';



Backtrack command (Search menu)

Backtrack - this is also available as a toolbar button. When selected from the database view 
it will change the current location to the last selected cell. Note that only cells which are 
explicitly selected by using the mouse or by using a find command, will be stored for 
possible backtracking. This command is useful for navigating around the database when 
entering the various lines in a pedigree.



Table New command (Table menu)

Creates a new table within the current database file. A dialog box prompts for the name of 
the table.

A maximum of 10 tables is currently allowed within BM. Four    tables are currently defined 
and the remaining tables should be considered reserved.

Note pedigree data for separate breeds would be stored in separate files, not tables, and 
there is no limit imposed by BM on the number of files you can maintain.



Table Delete command (Table menu)

Deletes the current table from the current database file. The Entry table cannot be deleted.



Table Select command (Table menu)

The bottom of the Table menu lists all the table in the current database. Select a new current
table from the list. The current table has a check mark against it.





User Interface
The elements are:
· Title bar - this is the area at the top of the window containing the text 'Breed 

Mate - [SAMPLE.BMF]'.
· Menu bar - contains the names of the menu headings, 'File Edit Search Mark 

Table View Window Help'.
· Tool bar - this is the row of buttons immediately below the menu bar.
· Status bar - this is located at the bottom of the window. It displays messages 

such as a description of the function of the current selected menu command. 
Part of the status bar, on the right hand side will also display the entry at the 
top of the database view when the vertical scroll button is dragged.

· Dialog bar - located immediately below the toolbar. It also contains the Edit 
Box.

· Edit box (part of Dialog Bar) - this is where any text is entered either to add or 
modify data in the database or for searches and mark functions (except Find 
Replace).

· Text Buttons (part of Dialog Bar) - there are six text buttons located below the 
edit box.

· Horizontal and vertical scroll bars;
· Coordinates - in the database view this will show the entry that would appear 

at the top of the view when the vertical scroll button is being dragged. In forms
view it shows the X and Y location of the mouse with respect to the origin. The 
origin by default is the top left of a form, but this can be changed by using the 
View - Set Origin command.

· View - this is the rectangular area bounded by the scroll bars and the dialog 
bar. It is used to display a view of the database, family tree or pedigree.

These elements are explained further below.
7.1 Mouse
Mouse input generally involves moving the mouse cursor above a user interface 
element, eg a menu command, and clicking or double clicking with the left mouse 
button. The right mouse button is not used. The term clicking generally means to 
press the mouse button and release it, however the term click and drag means to 
press the mouse button and keeping it pressed, move the mouse then release the 
button. Double clicking means to click the mouse twice in rapid succession - the 
maximum period between the clicks is set by the mouse utility in the control panel 
application in the 'Main' window of the Windows Program Manager.

7.2 Keyboard Commands
Some commands can be accessed via the keyboard. In describing keyboard 
commands the term 'hit' means to press that key and release it. Some keyboard 
commands require one or more keys to be pressed at the same time. These are 
shown separated by a plus sign, '+' and always involve one or more of the three 
'modifier' keys, ie the shift key 'Shft', the alt key 'Alt' or the control key 'Ctrl'. When 



doing such a key combination always press the modifier keys down before hitting 
the other key, eg a command which specifies 'Ctrl+Delete' means, press the control
key, then press the delete key and then release both keys. 

7.3 Title Bar
The title bar displays the name of the database file in square brackets. As shown in 
Figure 7.1 this would be 'sample.bmf'. The title bar can be used to reposition the 
whole window on the screen by clicking on it and dragging. You can also alternately 
maximise and minimise the window by double clicking on it.

7.4 Menu Bar
Most commands are available from the menu bar. Commands are grouped under 
menu headings. To see the commands under a particular heading, select a heading 
by clicking the left mouse button while the cursor is on it - all the commands under 
that heading are then displayed. Any one of the displayed commands can then be 
executed by clicking on it. Note that the menu headings and menu items will vary 
depending on what view you are in, eg from the pedigree view, no mark commands 
are available.
Some of the commands are also accessible from the keyboard in either one or two 
different ways. The first method is to hit the ALT key and then hit the first letter of 
the menu heading, eg to display the File menu, hit ALT and then the F key. Next hit 
the key for the letter which is underlined in the command, eg under the File menu 
the save command appears as 'Save', so to execute it from the keyboard the 
complete sequence of keystrokes is ALT, F, S. Note the ALT key does not need to be 
kept pressed.
The second method of accessing some commands is to enter the keystroke which is 
displayed next to the menu item, eg the 'Add Entry' command can be executed 
simply by hitting the 'F5' key.
Menu commands are sometimes referred to as Menu-Command, for example, the 
Add Entry command on the Edit menu would be referred to as Edit-Add Entry.

7.5 Status Bar
This is the area of the window at the bottom. It is used principally to print a 
message describing commands as they are selected from the menu or tool bar. A 
simple way of finding what each menu command is, is to select it from the menu by 
keeping the left mouse button pressed - when you have finished reading the 
command description, pull the cursor away until no commands are selected then 
release the mouse button. This also works with tool bar buttons - just place the 
cursor above the button, press the left mouse button then pull the mouse away 
from the button before releasing - this will still print a description of the command in
the status bar but will not activate the command.
The right hand side of the status bar is also used in the database view to display the
name of the entry at the top of the view when the vertical scroll button is being 
dragged. This allows rapid scrolling to a desired area in the database.

7.6 Views
The information in a database file can be viewed in one of three possible ways:



· database view;
· forms view;
· forms designer view;
The database view is similar to a spreadsheet where each entry is a row and each 
item of information for that entry appears in a separate column. Note that entries 
are always listed in the alphabetic order of the entry’s name.
The form view shows the currently selected entry on the currently selected form. It 
does not show all the information that the database view does.
The Forms Designer view (Breed Mate Pro only) allows the user to edit forms or 
create new forms.
Now for all these views the following rules apply:
· Any view can be printed or you can print preview it.
· Fields can be selected in the database and forms views by simply clicking on a 

particular field with the left mouse button. The field will then be highlighted in 
yellow. Once a field is highlighted, it can be updated by editing the text in the 
edit box and hitting Enter.

· The user can switch views at any time by selecting any of the view tool bar 
buttons (see User Reference Manual).

· In the database view you can go to the family tree of an entry by double 
clicking on it.

7.7 Minimise / Maximise Buttons
Clicking on the maximise button (up arrow) ' or double clicking in the Title Bar ' will 
resize the Breed Mate window to fill the whole screen. This button will then change 
to an up and down arrow symbol and when the user clicks on it again, it will restore 
the Breed Mate window to the size it was before it was maximised
Clicking on the minimise button will make Breed Mate an icon on the desktop. To 
restore Breed Mate, select 'Restore' from the menu accessed by clicking the icon.
The overall Breed Mate window size can be adjusted by clicking in the resizing bars 
and dragging. Note that the cursor changes to a double headed arrow when it is 
above the resizing bar.
Breed Mate remembers the size and position of its window and will restore it each 
time the program is started. It also remembers the last database opened and will 
automatically open this for you when you start the program.

7.8 Scroll bars
Most of the views will not fit entirely in the Breed Mate window, hence Breed Mate 
allows you to scroll (pan) around the view by using the scroll bars. The vertical scroll
bar will move the view vertically and similarly for the horizontal scroll bar.
When the scroll button is dragged, the view will only pan to a given position when 
the button is released. In the database view, the entry which would appear at the 
top of the view (if the mouse button was released) is displayed in the staus bar 
when the vertical scroll button is being dragged.



7.9 Regions
From the database view it is possible to select a region of cells rather than just a 
single cell. A region is defined as a rectangular area encompassing a range of 
entries and fields.
To select a single cell, move your mouse’s cursor above that cell and just click the 
left mouse button. To select a region you first select a cell at one corner of the 
region (say top left) and then select the diagonally opposite cell in the region but 
with the shift key pressed. The entire region will now be hilighted in yellow. 



Forms Basics
This section describes the very limited set of form editing commands available in 
standard Breed Mate. Breed Mate Pro users should refer to their Breed Mate Pro 
manual.
The purpose of editing forms, in standard Breed Mate is simply to adjust the position
of fields when printing on pre printed forms, eg show entries. Most printers have 
slight variations in the position and scale at which they print resulting in 
misalignment of text with respect to the pre printed form.
To edit a form first go to the form view and select the form you wish to edit from the
Form menu. Next select the edit mode by clicking on the edit button.
The view will change radically. Two samples of a form in normal and then in edit 
mode are shown below.

Figure 14.1 Example of form in form view.



Figure 14.2 Example of form in forms designer view.
Before discussing how the form can be edited, the following items need to be 
defined:
text This is static text, ie it does not change when a different entry is 

selected. Static text is shown in a black colour.
lines These are also static and are also shown in black.
rectangles As above.
records These appear as green rectangles.
fields These appear as blue rectangles. Fields should always be contained 

within records.
links These appear as red lines with the a black blob at one end. Links are 

used to join records (green rectangles). A link should always start in 
one record and end in another.

14.1 Moving Objects
To move entities, you first select them as follows:
· select a single entry by clicking on them with the mouse;
· select a group of entities wihtin an are by clicking at the top left of the area, 

dragging the mouse down to the bottom right of the area and releasing the 
mouse button; 

· keep selecting more entries by pressing the Shift key down while performing 



either of the previous.
When moving entities ensure that the original relationships between the records, 

fields and links is maintained, ie that fields remain within their records and that
links start and end within their original records.

14.2 Changing Fields
Changing fields is useful if you want to see different information displayed in a form,
eg a pedigree. The available fields include all the usual fields which are defined in 
your tables plus a list of 'calculated' fields as follows:
· title!+name +imported!+obedience
· title+name +imported+obedience
· title!+name+imported!+reg+colour
· title+name+imported+reg+colour
· title+name+reg+colour+breed
· title!+name!+reg+colour+breed
· breed
· street number+street+suburb+phone
The fields listed above are concatenated, ie joined together with a space character 
separating them, except where a ‘!’ is shown in which case a newline character is 
inserted causing following text to start on the next line.
To change a field, go to edit mode then select the field by clicking on it. Next click 
on the list box to display the available fields, select the field, then hit Enter or click 
on the green tick.
The example below shows the date field from a show entry form selected (solid 
black squares in each corner) and a list of available fields in the drop down list box.



Forms
Create a new field A user defined field is created by simply naming 

one of the existing unused fields. This can be done 
by clicking in the cell at the top of that column - its 
the one that looks like a button. It will be 
highlighted in yellow and the existing field name, if 
any, will appear in the dialog bar. It can now be set 
by simply entering the field name in the dialog bar 
and hitting enter or clicking the arrow button in the 
dialog bar.

Change Field Width In the database view move the cursor so that it is 
above the right hand boundary of the field - it will 
change to a double headed arrow - then press the 
mouse button and drag. Release the button when 
the desired width is set.

Change Field Name In the database view select the cell containing the 
field name (button shaped cell at the top of the 
column), enter the name in the Edit Box and hit 
Enter.



Views
Change the size of 
the image in the 
form views 

Click on the Zoom In or Zoom Out tool bar buttons.

Change the size of 
the BM window

Move the cursor so that it is above the edge of the 
window - the cursor will change shape to a double 
headed arrow - when it does, click and drag the 
mouse to get the desired size. Double clicking the 
title bar will maximise / minimise the window.

Change the position 
of the BM window

Click in the title bar and drag window to its desired 
position.

Change the colours 
used to mark repeat
entries in forms

In the form view, select a record which has the 
colour you wish to change, then select Edit Colour 
from the Edit menu.

Create multiple 
views

Select Windows-Tile to see all the current views. 
Select Windows-New while in the database view, 
then select Window-Tile to see both views together.

Move around the 
database view

Use the horizontal or vertical scroll bars or use the 
keyboard commands, Page Up, Page Down, Home, 
End, left and right arrow, up and down arrow.

View Database Select Database from the View menu, or in family 
tree view double click on a node. The database view
for a specific entry can be seen by double clicking 
on that entry in the form view.

View a Form The form of a specific entry can be seen by double 
clicking on the entry in the database view - 
alternatively select an entry by clicking on it and 
then click on the Form button on the toolbar. The 
specific form on which the entry will be shown is 
selected via the Forms menu.

View a Form for a 
proposed mating

The form for a proposed mating can be viewed by 
selecting a range of cells with the sire and dam at 
either end of the range and then clicking on the 
Form button on the toolbar. To select a range of 
cells first click on the sire and then, holding the shift
key down, select the dam. If checking out several 
matings to a certain bitch check the Bright Idea in 
the Mark menu description.

View a different 
entry on the current 
form

Use the  or  buttons to select the previous or 
next entry in the database. To select a specific 
entry, double click on it from the database view.

View database and Select Windows Tile. Note, by double clicking on an 



form together. entry in one view you can see it come up in the 
other view.

View Show Results To view all show results, go to the database view 
and from the Table menu select Show. To view show 
results for a specific entry, click on a cell in the 
name field of the Show Table containing the entries 
name then select Mark Substring, then select View 
Marked Only.



Printing
This section lists, in brief how to perform various printing functions.

Print a list of all 
dogs belonging to a 
particular kennel

Select any cell in the name field, type the kennel 
prefix in the edit box and select Substring from the 
Mark menu. Next select Marked Only from the View 
menu and then Print from the File menu.

Print out all 
offspring of a 
selected entry - 

Select all offspring up to 1st or 2nd or 3rd or 4th or   
All generations. Then select File-Print.

Print all ancestors of
a selected entry

Select the entry then select Ancestors from the 
Mark menu. Next select Marked Only from the View 
menu and then print.

Print all dogs with a 
selected genetic 
disease

Select a cell in the GD field, enter the disease name
in the edit box and select Substring from the Mark 
menu.

Print an A3 form on 
A4 paper.

From the form view select File Page Setup and 
select Fit To Page and set the Paper Size to A4 then 
click OK. Next select File Print.

Print marks as a 
pattern (because 
printer shows 
colours as solid 
black)

In the form view select View Options. In the dialog 
box select Use Patterns not Colours. Note this 
option does not work for repeat colours.



How To



Marking
Mark ancestors Select the entry whose ancestor you wish to mark, 

then select Ancestors from the Mark menu.
Mark descendants Select the entry whose descendants you wish to 

mark then select Descendants from the Mark menu 
then choose an item from the sub menu, viz 1st, 
2nd, 3rd, 4th All. All descendants up to and 
including the selected generation will be marked.

Mark unreferenced 
sires, dams or 
names

Select Unreferenced from the Mark menu. All 
entries whose name field is not referenced by 
another entries sire or dam field will be marked. The
sire and dam fields will be marked if the name in 
that field cannot be found in the name field of 
another entry (ie the parents do not exist in the 
database).

Mark all show 
champions

Click on a cell in the Show Titles field which 
contains 'CH' or whichever show title you wish to 
mark. This will then appear in the Edit Box. Now 
select Mark Substring. This will now mark all entries
who have the string 'CH' in their Show Title field. 

Mark all show 
champions who are 
descendants of a 
particular entry

First, do as above, then select Mark Mark Blue, 
select the entry and select Mark Descendants The 
offspring will now be in blue and the champions in 
red. The final step is to select AND marks. Now only
entries which were marked in red and blue will be 
marked (in red).

Show a pedigree 
with champions 
displayed in red.

Use Mark Substring to mark all champions then in 
the forms view select View Options and select 
'Show marks as text colour'.

Mark all 
descendants of 
entry X or entry Y.

Select Mark Red, select entry X, select Mark 
Descendants select Mark Blue, select entry Y, select
Mark    Descendants select Mark AND.



Editing
Add a new entry From the database view or form view enter the 

name of the dog in the edit box then click on the 
single yellow arrow or hit F5 or select Add Entry 
from the Edit menu.

Change data The data in any cell can be changed by first clicking
on it - the data will then appear in the edit box 
where it can be modified - then hit Enter or click on 
the green tick button. Note that after updating a 
cell, the current selection will move to the next cell 
on the right thus facilitating entry of consecutive 
fields in an entry.

Copy the whole 
table to the 
clipboard

Click in the black rectangle in the top left corner of 
the database view then select Copy from the Edit 
menu.

Copy a range of 
entries to the 
clipboard

In the database view select the first entry by 
clicking in the index field (left most field containing 
the index number) then, while holding the SHIFT 
key down, select the last entry in the range by 
clicking on its index field then select Copy from the 
Edit menu.

Copy all dogs 
belonging to a 
particular kennel to 
a new database

Select any cell in the name field, type the kennel 
prefix in the edit box and select Substring from the 
Mark menu. Next select Marked Only from the View 
menu and then click in the black corner box to 
select all cells then select Copy from the Edit menu.
Create a new database and insert clipboard 
contents by selecting Insert from the Edit menu.

Copy all ancestors 
of a selected entry 
to a new database

Select the entry then select Ancestors from the 
Mark menu. Next select Marked Only from the View 
menu and then click in the black corner box to 
select all cells then select Copy from the Edit menu.
Create a new database and insert clipboard.

Copy quickly, the 
contents of one cell 
to another

Select the source cell, then click in that cell and 
drag across to the destination cell and release the 
mouse button. Note during dragging, the cursor 
changes to an arrow with a plus sign.

Delete an entry Select any cell in the entry then select Delete form 
the Edit menu.

Delete a range of 
entries

Select the range first by clicking on the top most 
cell then, holding shift down, click on the bottom 
most cell. Next select Edit-Delete. Note in View-
Marked Only mode - only marked entries are 



deleted.
Delete all marked 
entries

Select View Marked Only then select all records by 
clicking in the blue box in the top left of the view. 
Next select Edite Delete then turn off View Marked 
Only.



Finding and Replacing
Change all 
occurences of one 
string with another.

Use the Find Replace command from the Search 
menu.

Find occurrences of 
a string

Find Previous and Find Next in the Search menu will 
search the name, sire and dam fields for an entry 
which contains the text in the edit box as a 
substring. Use Find Replace to search all fields.

Find an entry with a 
given name

Enter the name in the edit box (or click on a cell 
that contains the name) then select Find Entry from 
the Search menu.

Save changes To save the changes you have made, select Save 
from the File menu.

Find an entry fast or 
find a close spelling 
to an entry

Use Find Fast under the Search menu. It will find the
first entry with the maximum number of matching 
characters.

Quickly scroll to a 
rough area.

Click on the vertical scroll bar button and drag it, 
noting the entry names displayed in the status bar 
chnage as you drag. When the button is released, 
the display will be shown starting from the entry in 
the scroll bar.

Finding marks, eg 
finding an entry 
which has just been 
added

The Find Mark command will search forward from 
the current position to find the next marked entry.



Common Problems
Family tree or other form doesn’t show ancestors.
BM constructs a tree by looking for an entry’s parents by matching the entry’s sire 
or dam field against an entry with the same name. The problem of not showing 
ancestors is therefore due to sire or dam names not matching the name field of 
another entry. BM ignores uppercase or lower case when matching, but it can fail to 
match if there are extra characters, eg spaces. If there are extra spaces at the 
beginning or end of a name or two or more spaces in between the words in a name 
then the match will fail.
One solution is to carefully check the name, or simply use copy and paste to 
transfer the name of one entry to the relevant sire or dam field of another entry.
Note that BM will automatically remove any spaces at the front or end of any data 
entered and will remove double spaces in between. This feature can be diabled via 
View Options in the database view.
No Forms are loaded. Use File    - Open and select *.FRM
This will occur if the forms file was closed, or could not be found. In fact this 
message can be issued even after the form is actually loaded.
If no form is loaded simply use File Open and select a form. Note you may have click
on the 'List Files of Type' list box and select *.FRM before you will see any forms 
files.
In the case where a forms file is loaded and the message still persists, just select 
the forms file by clicking on the Window menu and selecting the forms file.
Can't change the breed shown on the pedigree.
Use    View Options in the database view to set the default breed for your current 
database file. Alternatively if you are interbeeding, eg Group II cats, then you may 
have sveral breeds in the one file - in this case select the 'Use per entry breed' 
option and set the breed for each entry in the breed field.



Getting Started
This section describes how to get started with Breed Mate (BM) - ie how to view an 
existing database or to create your own and then how to view a family tree.

Brief Steps Extra Details
To run BM just double 
click on the BM icon in 
the Program Manager

You can also double click on the file 
'bm20.exe' from the File Manager or double 
click a BM database file, ie a file with the 
'.bmf' extension. BM will automatically read in 
the last database which you opened. If you 
wish to view a different database simply 
select 'Close' from the File menu and then 
open another database.

You can adjust the size 
and position of BM’s 
window.

To move the window, click in the title bar with 
the left mouse button and, keeping it pressed,
drag the window to the desired position and 
then release the button. To resize, position the
cursor over the bottom corner until it changes 
to a double headed arrow, then click the left 
mouse button and drag.

If the file 'sample.bmf' 
is not already open then 
open it via File Open.

BM is supplied with a sample database file 
called 'sample.bmf'. This file contains some of 
the ancestors of a single entry called 
'Gracelands Maddie'. Open the file using File 
Open. A File Open dialog box appears, first 
select the correct drive (usually C), then select
the folder - a list of files in that folder will 
appear, select the file and click on OK.

To see an entry’s 
pedigree, click on it, 
then click on the forms 
view button in the 
toolbar. Next select a 
pedigree form from the 
Forms menu.

You can also just double click on an entry.

To see a different form 
click on the Forms menu.

To see a different form, eg show entry, family 
tree or a different pedigree (there are at least 
three!) click on the Forms menu - all available 
forms are listed at the bottom - just select the 
one you want.

There are two forms files 
available, dog.frm and 
cat.frm. 

You can select a different forms file by closing 
your current forms file then do a File Open and
select 'List Files of Type' *.FRM. Open either 
dog.frm or cat.frm. If you intend to modify 
these files, you should back them up first.



In the forms view you can
switch over to the next 
or prev record that you 
are viewing by clicking on
the black arrow buttons 
on the toolbar.

If you were looking at the pedigree certificate 
for Almondene

To create your own 
breed file, close the 
existing file (File - Close) 
then create a database 
with File - New, then save
it using File - Save As. 
The file name should be 
related to the name of 
the breed, eg Border 
Collies could be saved as 
'borders.bmf'.

To create a new database select New from the
File menu. Initially the new database will have 
no entries and will have a default name. To 
add entries, type the name in the Edit Box 
then select Add Entry from the Edit menu or 
click the yellow arrow on the dialog bar. The 
other fields in the entry can be filled in by just 
typing the contents of a field and hitting Enter.
To set the name of your new database select 
Save As from the File menu, navigate the 
directories and set the file name.

To add an entry, first 
click on the Edit Box 
(beneath the Tool Bar) 
and type the name then 
click on the yellow arrow.

This creates an entry whose name field is the 
text you entered in the Edit Box. Note that the
next field (sex) is highlighted, ready for you to
enter data in this field. This works in either the
database or forms view.

To add further fields to 
your entry, type into the 
Edit Box and hit enter.

Each entry in the database has multiple fields 
or cells. These can be modified by selecting 
the cell with a single mouse click - the cell will
now be marked in yellow. The data in that cell 
will now be displayed in the Edit Box where it
can now be modified. After modifying the 
data, hit the Enter key or click on the 'tick' 
button in the dialog bar.

To save changes to the
database select Save 
DB from the File menu.
To print out a form 
select Print from the File 
menu

Make sure you are in the forms view first. It is 
not required to setup the printer for page size 
and orientation as this is done automatically 
from information stored within each form.

To print out the 
database select Print 
from the File menu while 
in the database view.

Note that you should first set up the printer 
for the required size and orientation of the 
paper by selecting Setup from the Print dialog 
box. The database view will always be printed 
at the same size.Note: By selecting a larger
paper size more entries or fields can be 
printed on a single sheet. Also try selecting 
landscape paper orientation from Print Setup 
under the File menu.

To view different parts Note these may or may not appear, 



of the database simply  
scroll, using the scroll 
bars at the right and 
bottom of the window.

depending on whether all the data can be 
shown on the screen at once.

To share data with 
other Breed Mate users 
simply give them a copy 
of your database file, eg 
pomeranian.bmf.

They can add the contents of that file to their 
own database by first opening their database 
file then selecting Merge from the File menu 
and selecting your file. Duplicate records from
the incoming file will be discarded. Records 
which have been added to the database are 
marked in red.

To backup your 
database just copy your 
database file to a floppy 
disk.

Note: It is recommended that working copies 
of your database files should be kept on your 
hard disk. This greatly improves speed of 
access. At the same time you should also 
regularly make copies of your database files 
on floppy disk and store these in a safe place.



Overview
Breed Mate comes supplied as the following:
· license agreement;
· one 3 1/2 inch installation disk;
· registration card with license number; and
· User Manual.
The installation disk contains the following:
· Breed Mate program called 'bm20.exe';
· an installation program called 'install.exe';
· a sample database file called 'sample.bmf'.
Breed Mate is compatible with Microsoft Windows 3.1, Wfw 3.11, WinNT and 
Windows 95. In addition your machine should have the following minimum 
requirements:
· 386 processor;
· 4Mbytes of RAM;
· 40Mbytes hard disk;
· 3 1/2 inch floppy drive;
· if using Win3.x then Windows must be enhanced mode (its normal mode);
Breed Mate is a very complex program yet it is easy to use and requires very few 
resources from the computer. The program itself uses only 320KB of disk space and 
a typical database with 1500 entries would be about 180KB in size.
All Breed Mate database files are in a proprietary database format but Breed Mate 
also allows you to import or export data in the comma separated value (CSV) text 
format. This is a format that can be imported or exported by most spreadsheet 
programs such as Microsoft Excel. In addition Version 2.0 now allows direct copy and
paste between Breed Mate and other Windows applications such as spreadsheets 
and word processors.
Each database file is usually specific to a particular breed of dog. The number and 
size of your files is usually only limited by your disk space. Each file has been 
nominally limited to 64,000 records and each record to 2000 bytes - for all practical 
purposes these limits would not be reached.
Each record in the database corresponds to a single animal. It lists such items as 
the entries name, sire, dam, registration, date of birth, colour, sex, titles and 
genetic disease status.



Keyboard Commands
A list of the available direct keyboard commands is shown below:

Enter Update Cell command - the contents of the Edit Box replaces the 
currently selected cell – the next field is then selected.

Delete The Delete key in the database view will clear the currently 
selecteds cells. It has no effect in the Forms View, but in the Forms 
Design View it will delete the currently selected item, eg line, text, 
record. Note when deleting text in the Edit Box, use the Backspace 
key instead.

F5 Add Entry command.
F6 Copy Entry command.
F7 Delete Entry command.
F8 Mark Region command.
Shft+F8 Clear Mark Region command.
F9 Find Entry command.
F10 Find Next command.
F11 Find Mark command.
F12 Find Replace command.
Ctrl+C In database view copies contents of selected database region to 

clipboard. In form designer view, copies selected objects to 
clipboard.

Ctrl+V In database view paste contents of clipboard to selected database 
region. In form designer view pastes selected objects from clipboard.

Ctrl+X Cut contents of selected database region to clipboard.
Ctrl+I Inserts contents of clipboard into database (creates new entries).
Page Down The database view will scroll down (ie towards the end of the 

file) by almost a full page length.
Page Up The database view will scroll up (ie towards the beginning of the file)

by almost a full page length.
Home The database view will scroll to the beginning of the file.
End The database view will scroll to the end of the file.
Left ArrowIn database view it moves to previous (left) field in database view. In 

forms edit view it will move selected items left one unit (either 1mm 
or 0.1mm depending on whether Snap To Grid is selected).

Right Arrow In database view it moves to next (right) field in database view.   
In forms edit view it will move selected items right one unit. In forms 
view it will select the next field and hilight it in yellow.

Up Arrow In database view it moves to previous record in database view. In 



forms edit view it will move selected items up one unit.
Down Arrow In database view it moves to next record in database view. In 

forms edit view it will move selected items down one unit.
Shft+Left Arrow Move to first field in database view.
Shft+Right Arrow Move to last field in database view.



Toolbar Buttons
The tool bar contains several buttons which are short cuts for some of the more 
commonly used menu commands. To use any of these, just click on the relevant 
button.
The following buttons are available in all views:

This is the Open File button. It is identical to the Open command from the File menu.
This is the Save File button. It is identical to the Save command from the File menu.
This is the Print File button. It is identical to the Print command from the File menu.
This button is equivalent to the Cut command from the Edit menu.
This button is equivalent to the Copy command from the Edit menu.
This button is equivalent to the Paste command from the Edit menu.
This button selects the database view.
This button selects the forms view.

The following buttons are exclusive to the database views:
Same as the View Marks menu command. Click on this button to view only marked records 

(either red or blue). If the button is shown as depressed, then the database is in View Marks Only mode. 
To return to normal view mode, just click the button again.

This is the Find Fast button. It is identical to selecting Find Fast from the Search menu.
This is the Find Entry button. It is identical to selecting Find Entry from the Search menu.
This is the Find Next button. It is identical to hitting the F10 key or selecting Find Next from the 

Search menu.
This is the Find Previous button. It is identical to selecting Find Previous from the Search menu.
This is the Find Mark button. It is identical to selecting Find Mark from the Search menu.
Backtrack button.    It is identical to selecting Backtrack from the Search menu.

The following buttons are exclusive to the forms view:
Edit Form button. Used to switch to forms designer view and back to form view. Unless you have

Breed Mate Pro, edit mode will only allow simple changes, eg the position of text.
Zoom In button. It will increase the view magnification thus making viewed objects appear larger.
Zoom Out button. It will decrease the view magnification thus making viewed objects appear 

smaller.
Display the previous record. This will cause the current form to be redisplayed but for the 

previous entry, eg if you had selected an entry called 'Ausone Marquette' and you hit this button then the 
form would be displayed for the previous record, say 'Ausone Laramee'.

Display the next record. Useful for stepping through your database and viewing data for the 
currently selected entry in a form.

Display the first record in the currently selected table.
Display the last record in the currently selected table.



Dialog Bar Buttons
The dialog bar is used for modifying data or creating new entries. It contains an Edit
Box and four coloured buttons.
The Edit Box will contain the data from the currently selected cell - note this is the 
cell which is highlighted in yellow. To modify this data simply click in the Edit Box 
and type your corrections and hit the enter key. To replace or delete part of the text,
click and drag the mouse across that part of the text in the Edit Box and hit the 
delete key or just type your replacement characters then hit Enter.
The buttons in the dialog bar are as follows:

(Green Tick) Equivalent to hitting the Enter key. In either database view or forms view this will 
cause the text in the Edit Box to replace the currently selected field (the one highlighted in yellow).

(Red Cross) This button is only available in the database view. It has no effect on the database 
contents, but simply replaces the data in the Edit Box with the data from the selected cell, ie it undoes any
changes made to the data in the Edit Box.

(Yellow Arrow) In either database view or forms view this will create a new entry in the database 
with first field set to the text in the Edit Box. Hence if you entered 'Magdala Sandringham' in the Edit 
Box and hit the Yellow Arrow then a new entry would be created with this name.

(Double Yellow Arrow) In the database view it is equivalent to the Copy Entry command under 
the Edit menu. After entering the name of a new entry in the Edit Box, click on this button to create a new
entry in the database which has all its other data copied from the currently selected entry. This command 
is useful when entering litters.



Mark Overview
This section covers mark commands. These are commands which will place a mark 
against the name, sire or dam field of an entry. There are four types of mark as 
follows:
· name field marked in red;
· name field marked in blue;
· sire field marked in blue;
· dam field marked in blue;
The sire and dam marks are only ever used for marking unreferenced entries. The 
name field marks, either red or blue, are the marks which are used by all mark 
commands.
The concept of marking in red or blue is new to Version 2.0. It allows the mark 
colour to be selected first - all following mark commands will then apply marks only 
in this colour (except Mark Unreferenced). Marks in the other colour will be 
unaffected (except via the AND Mark and OR Mark commands).
Marked entries can be seen in the forms and the database view. An entry which is 
marked will appear as follows:
· a red mark will red;
· a blue mark will appear blue;
· a red and a blue mark will appear magenta (purple);
Marks are temporary only, ie they are not saved in the database.
The mark commands are useful if displaying marked entries in the forms view. For 
example you could mark all descendants of an important ancestor and then display 
the family tree of an entry you are interested in and follow the line of descent from 
the important ancestor.
Remember the database view has a View Marked Only command which will cause 
only marked lines to be visible. Once it is in this mode you can also print, in which 
case only the marked dogs will be printed. You can also copy a selection to the 
clipboard in which case only marked lines in that selection would be copied. This 
would allow you to for example select all the offspring of a particular entry and then
copy them to the clipboard, create a new database and paste them in there.



AND Mark
This will logically AND together the blue and red marks to produce red marked only 
entries. All blue marks will be removed and the only marks remaining will be red 
marks on entries which were originally marked in both red and blue.
This command is useful for performing complex marking functions, eg if you wished 
to mark all entries that were descended from a particular entry and also carried a 
genetic disease you would first mark in blue, mark the descendants, then mark in 
red and use Mark Substring to mark all entries which contained the disease name in
their GD field. The final step is to use Mark AND Marks to mark entries which were 
both red and blue. The final result is that only entries which were descended from 
the selected dog AND which had the genetic disease, will be marked in red.



OR Marks
This will logically OR together the blue and red marks to produce red marked only 
entries. All entries with either red or blue marks will now be marked in red. 



Mark Red
This will cause any further marks to be red marks, eg if you have some existing 
entries marked in blue, then you select Mark Red then do a Mark Offspring, then 
newly marked entries will appear in red, the existing blue marked entries will remain
in blue unless they were also marked with red - in which case they will appear in 
magenta.



Mark Blue
This will cause any further marks to be blue marks, eg if you have some existing 
entries marked in red then you select Mark Blue then do a Mark Offspring, then 
newly marked entries will appear in blue the existing red marked entries will remain 
in red unless they were also marked with blue - in which case they will appear in 
magenta.



Form
To show the form just double click on an entry in the database view or select the 
entry by clicking once on it and select Form from the tool bar. The form view is now 
shown as it would appear when printed, ie with a page in the background. To view 
more or less of the form select the Zoom In and Zoom Out tool bar buttons or you 
can also use the scroll buttons to scroll the view.
To return to the database view just double click on an entry in the form view. You will
then return to that entry in the database.



Forms Option
Select this menu item to change some of the display options for forms via the dialog
box shown below.

Forms Options Dialog Box
The meaning of the options is as follows:
· Show Marks. If this is selected then a record which is marked will be 

displayed with a solid colour background corresponding to the mark’s colour, ie
records marked in red will appear with a solid red background, those marked in
blue wi;; appear with a blue background, and those marked red and blue will 
have a magenta background.

· Show Marks as Text Colour. If this option is selected, then a record’s mark 
will be shown as the text’s colour, ie all text in fields belonging to that record 
will appear with the marks colour. This command is useful for example for 
showing all champions in red, just use Mark Substring on 'CH' - the champions 
will then appear in red text on the pedigrees (or in fact in any form).

· Show Repeat Marks. Use this option to display up to 32 different mark 
colours for records which appear more than once in a form. Useful for finding 
repeat ancestors in a family tree.

· Use Patterns Not Colours. Some printers cannot display colours or shades 
of grey, instead they will show any colour as solid black, thus obscuring any 
text. In such cases, use this option to show red and blue marks as a pattern.

The other options are not relevant to forms users.



Form menu
New Form Create a new form 

within the current form 
file.

Delete Form Delete the current form 
within the current form 
file.

Rename Form Change the name of 
the current form.

Menu Order Change the position of 
this form in the menu 
listing described below.

Select Form Change the view to the 
selected form.



New Form
This command creates a new form within the currently open form file. After 
selecting this command a dialog box will appear requesting a name for the form.



Delete Form
This command deletes the currently selected form, but has no effect on the other 
forms within the currently open form file.



Rename Form
After selecting this command a dialog box will appear requesting a new name for 
the current form.



Select Form
At the bottom of the Form menu is a list of all the forms in the current form file. Just 
select a form to move the current view to that form. Note the currently selected 
form is shown with a check mark against it.



Show Results
Show results are stored in the Show table and will use the same records as the show
entry. In other words you would first create a show record for the show entry, then 
fill in the show results in that record.
To view the show results for one particular entry, click on that entry in the Pedigree 
table then hold Shift down while clicking on the Show button. Note, behind the 
scenes this just uses the standard Mark Substring and View Marked Only 
commands.
To view results for one particular judge, ie select the judge’s name by clicking on a 
cell containing the judges name - it will then appear in the edit box (alternately you 
can just type the name into the edit box). Next select Mark Substring, then View 
Marked Only.



Text Buttons
The dialog bar also contains some text buttons as shown below:

Each of these buttons corresponds to one of the tables in the database.
The buttons which have been added are, pedigrees, shows, heats/mates, medical, owner. These buttons 
will perform a different action in the following three conditions:

· No shift or control keys pressed - jumps to the relevant table and display data 
for all entries.

· Shift key pressed - jumps to the relevant table but uses 'view marked only' to 
only display records for the entry that was selected in the pedigree table when 
the key was pressed. For example to display only the show results for a 
particular entry, select that entry in the pedigree table, then holding the shift 
key down, click on the Show Results button.

· Control key pressed - jumps to the relevant table and adds a new record for the 
entry that was selected. For example to add a medical record for an entry, 
select that entry in the pedigree table, then holding the shift key down, click on 
the Medical button.



Change Case
This command is only available in the database view. It will change the case of all 
the data in the currently selected area (yellow highlight). The case can be changed 
to:

· lower case - all alphabetic characters will be changed to lower case;
· upper case - all alphabetic characters will be changed to upper case;
· title case - all alphabetic characters will be changed to lower case, except for 

the first character of each word;
· sentence case - all alphabetic characters will be changed to lower case, except 

for the first character of each field;

This command is useful eg when merging data from friends who may for whatever 
reasons have put all their data in upper case - you would then simply select the 
name, sire and dam fields (note these are not contiguous, therefore you would 
select the name field first by clicking on the heading, then change case, then do the
same for sire and dam) and change the case to title case (the normal).



Menu Order
This is a popup menu which has two sub menu items, viz Promote and Demote. If 
promote is selected, then the currently selected form will be moved up the list order
in the menu listing of the forms as described below. Demote will move the form 
down the list order.



Medical Records
The Medical table can be accessed by clicking on the Medical button. This table 
contains the medical records for all of your dogs (for whichever breed this file is for).
To see the medical records for a particular dog, select the dog from the Pedigree 
table first then click on the Medical button while holding the Shift key down. 
Alternativley, from the Medical table click on the dog’s name and then select Mark - 
Substring, then click    on the View Marks button .
If you would like to store additional information, it is a simple matter to add more 
fields and resize these fields.



Litter Records
The Litters table stores details on the litters of all your dogs / cats.
To see the litters records for a particular entry select the entry from the Pedigree 
table first then click on the Litters button while holding the Shift key down. 
Alternatively, from the Litters table click on the entries name and then select Mark - 
Substring, then click    on the View Marks button .
If you would like to store additional information, it is a simple matter to add more 
fields and resize these fields.



Tutorial
Views

Brief Steps Comments
Start BM with the 
sample.bmf file open.

You will see the 4 generation pedigree of 
Almondene Barandale Heather appear. You are 
now in the Forms view. This view sits on top of 
the database view and shows that data in a 
graphical form.

Switch to the database 
view by clicking on  in
the toolbar.

BM will switch to the database view. This is a 
spreadsheet like view with a row per record and
a column for each field. The database has five 
tables, the currently displayed table is the 
Pedigree table.

Switch to the owners 
details by clicking on 
the  button.

Data in the Owners table is now shown. You can
see what kind of data is in the other tables by 
clicking on the other Text buttons.

Switch back to the 
Pedigree table

 then double 
click on Almondene 
Beautys Lass.

This will switch back to the forms view and 
display the current form (four gen pedigree) for
Almondene Beautys Lass.

Select a different 
pedigree form by 
clicking on the Forms 
menu and then clicking 
on 5G Pedigree A4.

This displays the same dog but on a different 
pedigree form.

Click on the  button 
to view the previous 
record.

This will show data for the currently selected 
form but for but will show the data for the 
previous record. Keep clicking on this button to 
see previous dogs.

Select Window - Tile 
menu item.

This will split the view to show both the 
database and forms views at the same time. 
See Figure 8.4 for an example.

Click on the  button 
to increment the current
record.

Note how both the forms and database views 
change.

Double click on 
Almondene Celtic 
Beauty in the database 
view.

The pedigree for this entry will be displayed.

Double click on The database view will display the details for 



Almondene Charger in 
the Forms view (it 
appears as a 
grandparent).

this entry.

Change back to 
displaying just the forms
view by double clicking 
in the title bar of the 
forms (it should say 
dog.frm)

You are now ready to proceed to Section 5.2, 
just skip the first step in the next section.

Add / Delete / Edit
Brief Steps Comments
Start as in the previous 
section

You will see the 4 generation pedigree of 
Almondene Barandale Heather appear. You are 
now in the Forms view. This view sits on top of 
the database view and shows that data in a 
graphical form.

Switch to the database 
view by clicking on    .
Click in the Edit box and
type Almondene Delicia 
then hit the F5 key or 
click on the single 
yellow arrow.

This creates a new record for this dog and 
highlights the Sex field. 

Type F and hit Enter. This will enter ‘F’ as the Sex and the DOB field 
will now be highlighted. Enter a fictional DOB 
and hit Enter.

We’ll assume the sire is 
Almondene Charger. 
Instead of retyping this 
name in the Sire field, 
click once on the Name 
field of Almondene 
charger, then click again
(not too quickly or it will
be interpreted as a 
double click!) and drag 
the mouse cursor down 
to Almondene Delicia’s 
Sire field and release 
the mouse button.

This is drag and drop. Its a fast way of copying 
fields on screen.

Assume the Dam is 
Garion Maori Billambi. 

This copies the text Garion Maori Billambi to 
the clipboard.



Scroll down to this 
entry, click on its name 
and hit Ctrl-C (hold 
down the Ctrl key as 
you press the C key).
Scroll back to 
Almondene Delicia by 
clicking on the 
backtrack button  
and click on its Dam 
field then hit Ctrl-V.

This copies the clipboard contents into this 
field.



Order Form

BREED MATE FAX ORDER FORM

To:
Wild Systems (Australia)
Fax No: +61-2-9869-0854

From:

Name:___________________________________________

Address: ___________________________________
___________________________________
___________________________________
___________________________________

Phone no: _________________

Order Details:

Please supply the following (tick applicable):

Registered version of Breed Mate V2.0 (Standard Edition),
including 80 page manual and disk and Express International
Post for US$100.

Registered version of Breed Mate V2.0 (Professional Edition),
including deluxe manual and disk and Express International
Post for US$135.

Payment Details:

I wish to pay by          Mastercard        
 Visa: (tick    applicable):

Name on Card: ____________________________________
Card Number : ____________________________________
Expiry Date : ______



Cardholder's signature:      ______________________________



Copy Picture
In the forms view, this will copy all of the current form as a picture to the clipboard.
This can them be pasted into a word processor. In Word, it is suggested that a frame
is created first, then paste the picture into the frame so that it can be resized or 
repositioned.



Table Rename
Use this command to rename the currently selected table. A dialog box will appear, 
enter the new name in the edit box then hit OK. Hit Cancel to leave the table name 
unchanged. 
The name can be any sequence of up to 32 characters including spaces.






